Cisco 1921 как подключить

Настройка маршрутизатора CISCO1921/K9

Может подскажите чего умного .
Заранее благодарен.

Вот простенькая схема сети и конфиг маршрутизатора:

Technology Package License Information for Module:’c1900′

——————————————————————
Technology Technology-package Technology-package
Current Type Next reboot
——————————————————————
ipbase ipbasek9 Permanent ipbasek9
security None None None
data None None None

Configuration register is 0x2102

Current configuration : 1790 bytes
!
! Last configuration change at 16:33:35 Russia Thu Feb 12 2015 by admin
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname gateway
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
clock timezone Russia 4 0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
ip domain name is
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FCZ1545C2WU
!
!
username admin privilege 15 secret 5
username admin2 privilege 15 secret 5
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
interface GigabitEthernet0/0
description LOCAL
ip address 192.168.10.1 255.255.255.0
ip accounting output-packets
ip nat inside
ip nat enable
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description PREMIER
ip address dhcp
ip access-group FIREWALL in
no ip redirects
no ip proxy-arp
ip nat outside
ip nat enable
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface Vlan1
description LAN
no ip address
!
ip forward-protocol nd
!
ip http server
ip http authentication local
no ip http secure-server
!
ip dns server
ip nat inside source list NAT interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 213.108.182.1
!
ip access-list extended NAT
permit ip host 192.168.10.0 any
!
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
end

Источник

ИТ База знаний

Полезно

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

READ  Как подключить яндекс навигатор в автомобиле
Популярное и похожее

Настройка Site-To-Site IPSec VPN на Cisco

Настройка GRE туннеля на Cisco

Настройка Cisco Port-Security

Ручная фильтрация маршрутов OSPF

Управление состоянием интерфейсов на коммутаторах Cisco

Настройка Cisco Embedded Packet Capture

Сброс пароля в Cisco ASA Firewall

Grandstream GXP2200

Еженедельный дайджест

Настройка доступа к Cisco по SSH

В Cisco Packet Tracer

Между ними есть одно основное различие – в протоколе Telnet все данные передаются по сети в незашифрованном виде, а в случае SSH все команды шифруются специальным ключом. SSH был разработан как замена Telnet, для безопасного управления сетевыми устройствами через небезопасную сеть, такую как Интернет. На всякий случай запомните, что Telnet использует порт 22, а SSH – 23.

Поэтому наша рекомендация – используйте SSH всегда, когда возможно.

Настройка

Для начала, вам понадобится Packet Tracer – программа для эмуляции сетей от компании Cisco. Он полностью бесплатен и его можно скачать с сайта netacad.com после регистрации. Запустите Packet Tracer и приступим к настройке.

Постройте топологию как на скриншоте ниже – один компьютер и один коммутатор третьего уровня. Нужно будет подключить их между собой и приступить к настройке.

Готово? Теперь обеспечим сетевую связность и настроим интерфейс vlan 1 на коммутаторе, для этого введите следующие команды:

Если сразу после создания в консоли коммутатора будет вопрос начать ли диалог изначальной настройки – ответьте «No».

Далее, настроим сетевую карту компьютера – укажем сетевой адрес в настройках FastEthernet0: 192.168.1.2. По умолчанию все новые компьютеры будут находиться в vlan 1.

Теперь давайте попробуем пингануть коммутатор и зайти на него по протоколу telnet с нашего ПК на коммутатор – и вы увидите, что соединение будет отклонено по причине того, что мы еще не настроили аутентификацию на коммутаторе.

Перейдем к настройке аутентификации. Система поддерживает 20 виртуальных tty/vty линий для Telnet, SSH и FTP сервисов. Каждая сессия, использующая вышеупомянутый протокол занимает одну линию. Также можно усилить общую безопасность с помощью валидации запросов на авторизацию на устройстве. Перейдите обратно в режим общей конфигурации (conf t) на коммутаторе с помощью команды exit и введите следующие команды:

Пароль cisco, используемый в статье, является крайне небезопасным и служит исключительно для демонстрационных целей. Если вы оставите такой пароль на настоящем оборудовании, шансы, что вас взломают будут стремиться к бесконечности. Лучше используйте наш генератор устойчивых ко взлому паролей 🙂

Теперь снова попробуйте зайти по Telnet на свитч – все должно получиться! Однако, при попытке перейти к настройке и выполнении команды enable вы увидите, что это невозможно, по причине того, что не установлен пароль на глобальный режи enable.

READ  Как подключить удаленный рабочий стол линукс

Чтобы исправить это, введите следующие команды:

Попробуйте еще раз – теперь все должно получиться!

Теперь настроим SSH на коммутаторе – для этого обязательно нужно указать хостнейм, доменное имя и сгенерировать ключ шифрования.

Вводим следующие команды (из основного конфигурационного режима):

Выбираем длину ключа – по умолчанию значение стоит равным 512 битам, для SSH версии 2 минимальная длина составляет 768 бит. Генерация ключа займет некоторое время.

После генерации ключа продолжим настройку коммутатора:

Теперь зайти по протоколу Telnet уже не выйдет, так как мы заменили его на SSH. Попробуйте зайти по ssh, используя логин по умолчанию – admin. Давайте-ка поменяем его на что-то поприличнее (опять из conf t):

Теперь попробуйте зайти с рабочей станции на коммутатор и удостоверьтесь, что новые настройки вступили в силу.

Было полезно?

Почему?

😪 Мы тщательно прорабатываем каждый фидбек и отвечаем по итогам анализа. Напишите, пожалуйста, как мы сможем улучшить эту статью.

😍 Полезные IT – статьи от экспертов раз в неделю у вас в почте. Укажите свою дату рождения и мы не забудем поздравить вас.

Источник

Cisco 1921 как подключить

Добрый день всем гуру. Свалилась на меня проблема в виде данной сиськи(начальство общаясь с кем то из партнеров узнало и сказала купить и сделать, на мое изъявление желания дайте ка курсы,было сказаны что компьютершики должны знать все). В сиськах я новичок, полез в инет и с каждых форумов по чуть чуть вроде бы насобирал правильную конфигурацию, вроде как, ан нет. Обращаюсь к Вам с низким поклоном,помогите найти ошибку в файле конфигурации:

!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname internet
!
boot-start-marker
boot-end-marker
!
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
!
!
aaa session-id common
clock timezone Russia 4 0
!
!
!
!
!
!
!
ip domain name internet.mkg.local
ip name-server 195.54.192.33
ip name-server 195.54.192.39
ip name-server 8.8.8.8
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn FCZ17369061
!
!
archive
log config
logging enable
hidekeys
username (скрыл)
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description LOCAL
ip address 192.168.1.250 255.255.255.0
ip accounting output-packets
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Internet
ip address 195.91.195.15 255.255.255.224
ip access-group FIREWALL in
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
ip verify unicast reverse-path
duplex auto
speed auto
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list NAT interface GigabitEthernet0/1 overload
ip route 0.0.0.0 0.0.0.0 195.91.195.1
!
ip access-list extended FIREWALL
permit tcp any any eq 22
ip access-list extended NAT
permit ip host 192.168.1.0 any
!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

READ  Ваз 2110 как подключить разъем датчика скорости

У вас входящие на внешний адрес разрешены только на порт 22, уберите access-list с gi 0/1.
Входящие соединения на циску управляются через
line vty 0 15
access-group FIREWALL
И включать
ip verify unicast reverse-path
на аплинковом интерфейсе не надо, я подозреваю что вы не совсем понимаете что эта команда делает.

> У вас входящие на внешний адрес разрешены только на порт 22, уберите
> access-list с gi 0/1.
> Входящие соединения на циску управляются через
> line vty 0 15
> access-group FIREWALL
> И включать
> ip verify unicast reverse-path
> на аплинковом интерфейсе не надо, я подозреваю что вы не совсем понимаете
> что эта команда делает.

Спасибо тебе добрый человек. Все заработало! По поводу незнаю для чего, так и есть, списывал из разных чужих настроек.

Провайдер по маку не контролит. При пинге с циске выдает вот что:
internet#ping ya.ru
Translating «ya.ru». domain server (195.54.192.33) (195.54.192.39) (8.8.8.8)
% Unrecognized host or address, or protocol not running.

Задача просто получить доступ из внутренней сети к интернету.

Я надеюсь, вы осознаете, какую свинью подкладываете всем тем, кто столкнется с подобной проблемой в будущем? Вот из-за таких ситуаций и бытует мнение, что «компьютерщики знают все». Потом увольняют сисадминов из-за отказа написать обработку для 1с.

Уважаемый Аноним не беспокойтесь это было сказано с самого начала,что пока на курсы не отправит,конфигурация будет сделана по сборкам в инете и безопасность не гарантирована.

> Уважаемый Аноним не беспокойтесь это было сказано с самого начала,что пока на
> курсы не отправит,конфигурация будет сделана по сборкам в инете и безопасность
> не гарантирована.

Я вообще не понимаю, вам самому повышение квалификации (а значит, и возможность зарабатывать больше) нужны?

Повышение квалификации всегда нужно, но лимит на год одно обучение. В этом году обучение я уже проходил,жду следующего.

Источник

Поделиться с друзьями
Как подключить и установить...
Adblock
detector