1с как подключить внешнюю обработку к документу

Добавление внешней обработки в базу

В статье описан алгоритм подключения внешней обработки к вашей конфигурации 1С:Предприятие 8.2

Для БП 2.0, ЗУП 2.5, УТ 10.3, КА 1.1, УПП 1.3

В верхем меню заходим Сервис->Дополнительные отчеты и обработки->Дополнительные внешние обработки.

Появляется форма списка справочника внешних обработок. В верхнем меню нажимаем кнопку Добавить.

Появится форма добавление нового объект. Нажимаем но кнопку открыть, и выбираем файл с нужной обработкой. После того как вы выбрали нужный файл, при необходимости, задайте имя обработки(поле Наименование). После этого нужно нажать ОК, чтобы сохранить сделанные изменения.

После этого окно создания элемента справочника закрывается, и вы попадаете обратно на форму списка, в которой уже присутствует новая обработка.

На этом все! Процесс добавления обработки в конфигурацию завершен. Чтобы впоследствии открывать эту обработку, заходите по старому пути: Сервис->Дополнительные отчеты и обработки->Дополнительные внешние обработки.

Для БП 3.0, ЗУП 3.0, УТ 11, ERP 2.0.

Внешние обработки для 1С:Предприятие 8 бывают нескольких видов. В данной инструкции я покажу, как прикреплять обработки по групповой модификации и обработки по заполнению конкретных объектов.

Для первого случая добавим обработку по заполнению справочника номенклатуры из Эксель.

Переходим в соответствующий раздел программы:

Необходимо, чтобы был установлен признак использования дополнительных отчетов и обработок, переходим по гиперссылке в список внешних объектов:

READ  Как подключить два телевизора к одной спутниковой антенне схема

В списке нажимаем Создать:

В открывшемся диалоговом окне выбираем нужный файл с обработкой:

Заполнилась карточка нового внешнего объекта в программе, осталось только настроить размещение (разделы программы, из которых будет доступна обработка):

В качестве размещения выбираем произвольный раздел (или несколько):

Записываем и закрываем карточку внешнего объекта:

Теперь откроем обработку из интерфейса:

Список пустой, нажимаем Настроить список:

Выбираем нашу обработку:

Теперь она доступна для выбора. Чтобы открыть обработку, нужно нажать Выполнить:

Теперь посмотрим, как добавляется обработка по заполнению (модификации) конкретных объектов. Для примера возьмем внешнюю обработку, которая прикрепляет сканы к выбранным элементам справочников или документам системы. Начало добавления такой обработки не отличается от предыдущего варианта. Различие в том, что в данном случае размещение заполняется автоматически (и не разделом программы, а типами объектов базы):

При желании список размещения можно скорректировать (не добавить дополнительное размещение, а убрать лишнее):

Для принятия изменения карточку внешнего объекта также нужно записать.

Для того, чтобы воспользоваться обработкой, необходимо зайти в конкретный объект базы (из списка размещения), нажать пункт Заполнить в командной панели и выбрать команду:

Источник

Подключение внешней обработки к документу

Подключаю внешнюю обработку к документу через внешние обработки.
Управляемый интерфейс такси. Вставил в модуль обработки следующий код.
Выдается ошибка. Код брал из типовой обработки для примера. Что нужно добавить или исправить?

//
#Область ПрограммныйИнтерфейс
//
Функция СведенияОВнешнейОбработке() Экспорт
// перед заполнением данной функции
// 1. Назначьте имя текущей обработки.
// Оно должно быть уникальным в пределах справочника внешних обработок.
// Например, ПечатьЗаказаСХарактеристиками
// 2. Назначьте синоним текущей обработки.
// Например, «Печать заказа с характеристиками»
ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке(«2.2.2.1»);
ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
ПараметрыРегистрации.Назначение.Добавить(«ЗаказНаПеремещение»);
ПараметрыРегистрации.Назначение.Добавить(«Документ.*»); // все документы
//НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
//НоваяКоманда.Представление = «Заполнить заказ на перемещение (сервер)»;
//НоваяКоманда.Идентификатор = «ЗаполнитьЗаказСервер»;
//НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
//НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
//НоваяКоманда.Представление = «Заполнить заказ на перемещение (заполнение формы)»;
//НоваяКоманда.Идентификатор = «ЗаполнитьЗаказЗаполнениеФормы»;
//НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыЗаполнениеФормы();
//НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
//НоваяКоманда.Представление = «Заполнить заказ на перемещение (клиент)»;
//НоваяКоманда.Идентификатор = «ЗаполнитьЗаказКлиент»;
//НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовКлиентскогоМетода();
НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
НоваяКоманда.Представление = «Заполнить заказ на перемещение (открытие формы)»;
НоваяКоманда.Идентификатор = «ЗаполнитьЗаказФорма»;
НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
Возврат ПараметрыРегистрации;
КонецФункции
//
Процедура ВыполнитьКоманду(ИмяКоманды, ОбъектыНазначения, ПараметрыВыполнения = Неопределено) Экспорт
Если ИмяКоманды = «ЗаполнитьЗаказСервер» Тогда
ЗаполнитьЗаказПоСсылке(ОбъектыНазначения, ПараметрыВыполнения.РезультатВыполнения, ИмяКоманды);
ИначеЕсли ИмяКоманды = «ЗаполнитьЗаказЗаполнениеФормы» Тогда
ЗаполнитьФормуЗаказа(ПараметрыВыполнения.ЭтаФорма, ПараметрыВыполнения.РезультатВыполнения, ИмяКоманды);
КонецЕсли;
КонецПроцедуры
//
#КонецОбласти
//
#Область СлужебныеПроцедурыИФункции
//
Процедура ЗаполнитьЗаказПоСсылке(МассивСсылок, РезультатВыполнения, ИмяКоманды)
Для Каждого Ссылка Из МассивСсылок Цикл
Объект = Ссылка.ПолучитьОбъект();
Объект.Дата = Объект.Дата + 60*60*24;
Объект.Записать();
КонецЦикла;
СтандартныеПодсистемыКлиентСервер.ВывестиОповещение(
РезультатВыполнения,
«Дата документов изменена»,
,
БиблиотекаКартинок.УстановитьФлажки);
КонецПроцедуры
//
Процедура ЗаполнитьФормуЗаказа(Форма, РезультатВыполнения, ИмяКоманды)
Форма.Модифицированность = Истина;
Объект = Форма.Объект;
Объект.Дата = Объект.Дата + 60 * 60 * 24;
СтандартныеПодсистемыКлиентСервер.ВывестиОповещение(
РезультатВыполнения,
«Дата документов изменена»,
,
БиблиотекаКартинок.УстановитьФлажки);
КонецПроцедуры
//
#КонецОбласти

READ  Как подключить ноутбук к планшету через usb для выхода в интернет

Источник

Внешние обработки табличных частей в 1С 8.2 и 8.3

Табличные части в документах и справочниках часто бывают достаточно большими — сотни и тысячи строк. Почти также часто требуется выполнять какую-либо обработку этих самых строк и разумеется очень желательно автоматизировать эту обработку. Изменять конфигурацию в каждом подобном случае было бы очень непрактично, поэтому компания «1С» создала механизм внешних обработок табличных частей.

Внешняя обработка табличных частей — это обычная внешняя обработка, соответствующая определенным требованиям. Такую обработку можно подключить к какой-либо типовой конфигурации и привязать к нужным документам и справочникам.

Кроме этого, нужно отметить, что создание внешних обработок табличных частей различается для обычного приложения (Бухгалтерия 2.0.*, ЗиУП 2.5.*, УТ 10.3.*) и управляемого приложения (Бухгалтерия 3.0.*, ЗиУП 3.*, УТ 11.*). В статье будут рассмотрены оба варианта.

Также нужно сказать, что вопросы отладки внешних обработок табличных частей для управляемого и для обычного приложения рассматриваются в отдельной статье.

Внешняя обработка табличных частей в управляемом приложении

Начнем с управляемого приложения. Тут нужно сказать, что в управляемом приложении обработки табличных частей заменены на более общие обработки заполнение объекта. В тексте ниже будет приведен пример создания и подключения обработки заполнения объекта на примере документа «Реализация товаров и услуг» (Бухгалтерия предприятия, редакция 3.0).

Создание

Итак, для начала нам нужно создать новую внешнюю обработку и в модуле объекта этой обработки размещаем такой код:

В коде реализована экспортная функция СведенияОВнешнейОбработке(), она является обязательной и служит для описания внешнего обработки. Обязательными для заполнения являются параметры «Вид» (в нашем случае — «ЗаполнениеОбъекта»), «Версия» и «Команды». Необязательные параметры также очень желательно заполнять — это облегчает подключение и помогает избежать путаницы в дальнейшем.

READ  Как подключить ip камеру к ноутбуку для настройки

Параметр «БезопасныйРежим» в значении «Истина» накладывает некоторые ограничения:

При этом имеется возможность запросить исключения из безопасного режима (приме в коже выше).

В примере выше добавляются три команды разного типа. Команды типов «ВызовСерверногоМетода» и «ЗаполнениеФормы» должны быть реализованы в том же самом модуле объекта обработки — экспортная процедура ВыполнитьКоманду(). При этом команды типа «ЗаполнениеФормы» могут выполняться для новых (не записанных) объектов. Пример реализации:

Источник

Поделиться с друзьями
Как подключить и установить...
Adblock
detector